You are currently viewing Como Criar backup do RouterOS/Mikrotik e enviar via FTP

Como Criar backup do RouterOS/Mikrotik e enviar via FTP

O que é um Backup?

cópia de segurança é a cópia de dados de um dispositivo de armazenamento a outro para que possam ser restaurados em caso da perda dos dados originais, o que pode envolver apagamentos acidentais ou corrupção de dados.

Nesse post vou ensinar como fazer backup do Mikrotik Router OS de forma automática e envio automático para o servidor externo.

Instalação

Requisitos:

servidor FTP

nesse tutorial vou usar o Pure-FTPd para fazer o backup automático.

Vamos ao script, você precisa alterar:
:global host ____IP/DNS_SERVIDOR_FTP____
:global usuario ____USER____
:global senha ____SENHA____
:global diretorio ____pastaX____

Acesse o menu: System >> Script e depois em [+]

O nome do arquivo será o mesmo que você definiu em System >> Identity, serão criado dois arquivos, uma backup e um export (AAAA-MM-DD.NOME.backup AAAA-MM-DD.NOME.rsc)

:log warning “***”

Conexão FTP

:global host IP/DNS_SERVIDOR_FTP
:global usuario USER
:global senha SENHA
:global diretorio pastaX

Pega o nome do Router

:global identifica [/system identity get name ];

Gera data no formato AAAA-MM-DD

:global data [/system clock get date]
:global meses ("jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec");
:global ano ([:pick $data 7 11])
:global mestxt ([:pick $data 0 3])
:global mm ([ :find $meses $mestxt -1 ] + 1);
:if ($mm < 10) do={ :set mm ("0" . $mm); } :global mes ([:pick $ds 7 11] . $mm . [:pick $ds 4 6]) :global dia ([:pick $data 4 6]) :log info "Gerando backup: $ano-$mes-$dia.$identifica.backup"; /system backup save name="$ano-$mes-$dia.$identifica"; :log info "Gerando export: $ano-$mes-$dia.$identifica.rsc"; /export file="$ano-$mes-$dia.$identifica" :log info "Processando…"; :delay 5s :log info "Conectando FTP Server…"; :log info "Enviando Backup [$ano-$mes-$dia.$identifica.backup] …"; /tool fetch address=$host src-path="$ano-$mes-$dia.$identifica.backup" user="$usuario" password="$senha" port=21 upload=yes mode=ftp dst-path="$diretorio/$ano-$mes-$dia.$identifica.backup" :log info "Enviando Export [$ano-$mes-$dia.$identifica.rsc] …"; /tool fetch address=$host src-path="$ano-$mes-$dia.$identifica.rsc" user="$usuario" password="$senha" port=21 upload=yes mode=ftp dst-path="$diretorio/$ano-$mes-$dia.$identifica.rsc" :delay 1 :log info "Backup enviado com sucesso…"; :log info "Removendo arquivos…"; /file remove "$ano-$mes-$dia.$identifica.backup" /file remove "$ano-$mes-$dia.$identifica.rsc" :log info "Rotina de backup finalizada…"; :log warning "***";

Agora será preciso agenda-lo para execução a cada X período, no meu exemplo vou definir que todos os meio dias a cada 3 dias. Ajuste de acordo com suas necessidades:
Acesse o menu: System >> Scheduler [+]

Pronto, rapidinho, backup automatizado. agora é só testar e verificar no servidor 😉

Ivan Junior

Trabalho atualmente como Administrador de Redes em um Provedor de Internet no interior da Bahia.

Deixe um comentário